Sep 19, 2017, 02:45 pm

News:

Ufasoft Coin 0.110 new features: SOCKS5, TOR,
bootstrap.dat DB format


Trying to make lisp-4.35 work with VS 2013

Started by LogiMan, Apr 22, 2016, 09:13 pm

previous topic - next topic
Go Down

LogiMan

Apr 22, 2016, 09:13 pm Last Edit: Apr 22, 2016, 09:16 pm by LogiMan
I downloaded the .tar.xz file from your site, unzipped to a C:\ufasoft_lisp-4.35 directory.
Installed VS 2013 and try to open lisp-2013.sln.
I am getting this message:
Unsupported
This version of Visual Studio is unable to open the following projects. The project types may not be installed or this version of Visual Studio may not support them.
For more information on enabling these project types or otherwise migrating your assets, please see the details in the "Migration Report" displayed after clicking OK.
- lispeng, "C:\ufasoft_lisp-4.35\src\lispeng\lispeng.vcxproj"
- lispideui, "C:\ufasoft_lisp-4.35\src\lispideui\lispideui.vcxproj"
- lispdev, "C:\ufasoft_lisp-4.35\src\lispdev\lispdev.vcxproj"
No changes required
These projects can be opened in Visual Studio 2013, Visual Studio 2012, and Visual Studio 2010 SP1 without changing them.
- lisp-2013, "C:\ufasoft_lisp-4.35\lisp-2013.sln"

OS Windows 10

Any comments? Thanks in advance.

ufasoft

The archive of source code build was not tested carefully.
So some manual changes required.

Thank you for informing us about the problem.

LogiMan

Thank you for your quick answer.
Do you have a timetable for a possible solution?
Is there a previous version that works that can be downloaded?
Thank you again.

ufasoft

The latest version available at  GitHub:


git clone --recursive https://github.com/ufasoft/lisp


lisp.sln
configuration: console-release

LogiMan

Thanks again for your quick answer.
I am using VS 2013 Shell (integrated).
I tried to install the Github extension in VS and I am getting a "SignatureDescription could not be created for the signature algorithm supplied." error.
So I downloaded the zip file from the Github unzipped to C:\lisp-master directory open lisp-2013.sln but I am getting the same error as before.
I am a retired mechanical engineer. I did a bunch of programming and would like to explore in Lisp a couple of ideas that I have in mind. I saw your application as a viable way to have a non to complicated IDE to do the exploration. If you think that it is going to be a hassle for an amateur like me to put everything to work, please advise and I will look on some other direction.
Thank you for your attention. 

ufasoft

Our Lisp integration with VS Shell does not work with last versions of VS Shell (2013/2015).
Some VS APIs were changed.

If you want just command line Lisp, you can download  Windows EXE:
http://ufasoft.com/files/ufasoft_lisp_4.36.exe

or CLISP (our Lisp based on CLISP).

LogiMan

Sorry my antivirus complains about running ufasoft_lisp_4.36.exe.
Thank you for your help, but I will be looking somewhere else to find something that works for my needs.
Have a nice day.

Go Up